Skip to content
LLMHigh

CVE-2025-62164: vLLM is an inference and serving engine for large language models (LLMs). From versions 0.10.2 to be…

Occurred
Nov 21, 2025
Published
Nov 21, 2025
Source
NVD CVE

Summary

vLLM is an inference and serving engine for large language models (LLMs). From versions 0.10.2 to before 0.11.1, a memory corruption vulnerability could lead to a crash (denial-of-service) and potentially remote code execution (RCE), exists in the Completions API endpoint. When processing user-supplied prompt embeddings, the endpoint loads serialized tensors using torch.load() without sufficient validation. Due to a change introduced in PyTorch 2.8.0, sparse tensor integrity checks are disabled by default. As a result, maliciously crafted tensors can bypass internal bounds checks and trigger an out-of-bounds memory write during the call to to_dense(). This memory corruption can crash vLLM and potentially lead to code execution on the server hosting vLLM. This issue has been patched in version 0.11.1.

Tags

  • CVE
  • CVE-2025-62164
  • cvss:HIGH

Classification

Category confidence: 95%
Severity confidence: 90%

Rationale: vLLM is an LLM serving engine with a critical RCE vulnerability in its API endpoint.

Classifier: Qwen/Qwen3.5-35B-A3B-FP8

Visit source