Skip to content
LLMMedium

CVE-2025-62372: vLLM is an inference and serving engine for large language models (LLMs). From version 0.5.5 to befo…

Occurred
Nov 21, 2025
Published
Nov 21, 2025
Source
NVD CVE

Summary

vLLM is an inference and serving engine for large language models (LLMs). From version 0.5.5 to before 0.11.1, users can crash the vLLM engine serving multimodal models by passing multimodal embedding inputs with correct ndim but incorrect shape (e.g. hidden dimension is wrong), regardless of whether the model is intended to support such inputs (as defined in the Supported Models page). This issue has been patched in version 0.11.1.

Tags

  • CVE
  • CVE-2025-62372
  • cvss:MEDIUM

Classification

Category confidence: 95%
Severity confidence: 90%

Rationale: CVE describes a denial-of-service vulnerability in vLLM LLM serving engine causing crashes via malformed inputs.

Classifier: Qwen/Qwen3.5-35B-A3B-FP8

Visit source