Skip to content
LLMHigh

CVE-2026-22778: vLLM is an inference and serving engine for large language models (LLMs). From 0.8.3 to before 0.14.…

Occurred
Feb 2, 2026
Published
Feb 2, 2026
Source
NVD CVE

Summary

vLLM is an inference and serving engine for large language models (LLMs). From 0.8.3 to before 0.14.1, when an invalid image is sent to vLLM's multimodal endpoint, PIL throws an error. vLLM returns this error to the client, leaking a heap address. With this leak, we reduce ASLR from 4 billion guesses to ~8 guesses. This vulnerability can be chained a heap overflow with JPEG2000 decoder in OpenCV/FFmpeg to achieve remote code execution. This vulnerability is fixed in 0.14.1.

Tags

  • CVE
  • CVE-2026-22778
  • cvss:CRITICAL

Classification

Category confidence: 95%
Severity confidence: 90%

Rationale: vLLM LLM serving engine vulnerability allows remote code execution via heap address leak and chained overflow.

Classifier: Qwen/Qwen3.5-35B-A3B-FP8

Visit source