LLMHigh
CVE-2025-59944: Cursor is a code editor built for programming with AI. Versions 1.6.23 and below contain case-sensit…
- Occurred
- Oct 3, 2025
- Published
- Oct 3, 2025
- Source
- NVD CVE
Summary
Cursor is a code editor built for programming with AI. Versions 1.6.23 and below contain case-sensitive checks in the way Cursor IDE protects its sensitive files (e.g., */.cursor/mcp.json), which allows attackers to modify the content of these files through prompt injection and achieve remote code execution. A prompt injection can lead to full RCE through modifying sensitive files on case-insensitive fileystems. This issue is fixed in version 1.7.
Tags
- CVE
- CVE-2025-59944
- cvss:HIGH
Classification
Category confidence: 90%
Severity confidence: 85%
Rationale: Prompt injection vulnerability in AI-powered code editor enables remote code execution.
Classifier: Qwen/Qwen3.5-35B-A3B-FP8