Skip to content
LLMHigh

CVE-2026-54232: vLLM is an inference and serving engine for large language models (LLMs). Prior to 0.22.1, the vLLM …

Occurred
Jun 22, 2026
Published
Jun 22, 2026
Source
NVD CVE

Summary

vLLM is an inference and serving engine for large language models (LLMs). Prior to 0.22.1, the vLLM Dockerfile is vulnerable to a dependency confusion attack through the flashinfer-jit-cache package. The package is installed from a custom index (flashinfer.ai/whl/) using --extra-index-url, but the package name was not registered on PyPI, and UV_INDEX_STRATEGY="unsafe-best-match" is set globally. An attacker who registers flashinfer-jit-cache on PyPI with version 0.6.11.post2 can execute arbitrary code as root during the Docker build and backdoor every resulting container image, enabling exfiltration of all user prompts, API credentials, and model data from production vLLM deployments This vulnerability is fixed in 0.22.1.

Tags

  • CVE
  • CVE-2026-54232
  • cvss:HIGH

Classification

Category confidence: 95%
Severity confidence: 90%

Rationale: vLLM LLM serving engine vulnerability allows arbitrary code execution and data exfiltration via dependency confusion attack.

Classifier: Qwen/Qwen3.5-35B-A3B-FP8

Visit source