Skip to content
AI AgentHigh

CVE-2026-75913: CodeWhale (codewhale / codewhale-tui) versions >= 0.8.41 and < 0.8.64 contain an argument injection …

Occurred
Aug 18, 2026
Published
Aug 18, 2026
Source
NVD CVE

Summary

CodeWhale (codewhale / codewhale-tui) versions >= 0.8.41 and < 0.8.64 contain an argument injection vulnerability in the git_show tool. The model-supplied rev parameter is passed unvalidated into the git show argv without an --end-of-options sentinel, so a value beginning with --output= is interpreted as a git flag. Because the tool is registered as auto-approved and advertised as read-only, an attacker (via a malicious repository combined with prompt injection) can cause an unprompted arbitrary file write at the privilege of the invoking user, targeting sensitive files such as ~/.ssh/authorized_keys, ~/.bashrc, or ~/.gitconfig. Fixed in 0.8.64 by adding rev validation.

Tags

  • CVE
  • CVE-2026-75913
  • cvss:CRITICAL
  • agent-fail:injection-direct
  • agent-cause:prompt-design

Classification

Category confidence: 95%
Severity confidence: 90%

Rationale: Agent tool injection vulnerability allows arbitrary file write via unvalidated parameters in a tool-using AI system.

Classifier: Qwen/Qwen3.5-35B-A3B-FP8

Visit source